Parametar upiti.htm

-

Napravili smo upit (1). U polje za kriterijum u koloni "Genre" uneli smo sledeću poruku [Enter a genre (rock, pop, holiday)]. Sada kliknemo na Design>Results>Run (2). Dobijamo poruku (3) i unosimo "rock". Sada dobijamo kao rezultat upit (4) u kome su izlistane samo pesme rok žanra. Ovo je primer parametarskog upita. Zavisno od toga koji parametar unesemo, upit će svaki put biti drugačiji.

-

Napravili smo upit (1). U polje "criteria" smo uneli kriterijum >[Enter a start year] and <[Enter a end year]. Sada kliknemo na Design>Results>Run (2). Prvo se pojavljuje dijalog (3), a za njim i dijalog (4). U njih unosimo početnu i krajnju godinu. Kao rezultat dobijamo upit (5) koji sadrži samo pesme objavljene u periodu između 1972 i 1982 godine.

- (>[Enter a start year] and <[Enter a end year]) može da se napiše i kao (Between [Enter a start year] and [Enter a end year])

-

Kada upisujemo sintaksu za parametar moramo paziti šta upisujemo. Ne smemo upisati ništa što liči na ime nekog drugog filda (0). Kada upišemo više parametarskih upita tada se oni sprovode sleva nadesno, u skladu sa redosledom fildova u kojima su ti upiti (1). Da bismo ovo izmenili idemo na Design>Show/Hide>Table Names i klikćemo na "Parametars" (2). Sada se otvara dijalog (3) u kome ukucamo parametarske upite onim redom kako želimo.

-

Običan parametarski upit (0) ne može da podrži "divlji" znak upit (1). Da bi ovo funkcionisalo moramo uvek da koristimo "Like" operater kada koristimo "divlje" znakove (2). Sada može (1). Parametarski upit možemo zapisati i ovako (3). To znači da ćemo pronaći svaki grad koji sadrži neka slova u imenu. Tada možemo vršiti upite kao (4).

-