New Item1.htm

-

Pretpostavimo da imamo neki tekst. U njemu želimo da je neka grupa kontrola povezana tako da kada upišemo nešto u jednu kontrolu, to isto se ponovo u povezanim kontrolama. Na slici vidimo dokument u kome smo napravili samo prvu kontrolu, a mesta gde želimo da se ta kontrola ponavlja smo obeležili žutom bojom. Ovaj fajl mora biti DOTX fajl.

-

Na sajtu http://dbe.codeplex.com/ (0) možemo pronaći "Word Content Control Toolkit" (1,2). Evo kako taj program izgleda kada se instalira (3).

-

U programu idemo na File>Open i otvaramo .dotx fajl za koji želimo da povežemo kontrole (0). Na levoj strani ćemo imati spisak svih kontrola koje koristimo (1). Klićemo na "Create a new Custom XML Part" (2), a zatim na tab "Edit View" (3). U novom oknu ćemo imati upisane root tagove (4). Sada treba sve kontrole sa leve strane (5) upisati na desnu stranu u vidu XML tagova. Između odgovarajućih tagova pišemo default tekst (6). Ovo je bitno jer svaki default tekst napravljen u Wordu će biti prepisan ovom akcijom. Kada zavrišimo sa pisanjem klikćemo na dugme (7) kako bismo dobili poruku koja nam kaže da li je upisivanje pravilno izvršeno (8). Sada treba da se vratimo u "Bind View" (9) i da prevlačimo XML stavke na odgovarajuću kontrolu (10). Svaki put kada to uradimo za neku kontrolu pojaviće se tekst (11) i taj red će biti plave boje. Na kraju idemo na File>Save(12).

-

Sada otvorimo dotx fajl. Kontrolu koju smo napravili (0) kopiramo na sva žuta mesta koja smo pre označili radi lakšeg snalaženja. Nakon ovoga naša kontrola će biti na više mesta u dokumentu (2). Sada kada upišemo nešto u (3) jednu od kontrola (to može biti bilo koja kontrola), sve ostale kontrole će prihvatiti taj isti tekst (4).

-